use strict;
my $str = '( ( \'1\' = \'1\' ) ) AND ( (eQFetchRule = \'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__Management)\' or eQFetchRule = \'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__CAE__Load__Geometry)\' ) )';
my $regex = qr/\( \( '1' = '1' \) \) AND \( \((?:eQFetchRule[ ]*=[ ]*'(?:[a-zA-Z0-9\.]+):(?:[A-Za-z0-9]+)\(([A-Za-z0-9_]+)\)'[ ]*[or]*[ ]*)+\) \)/p;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";