const regex = /\( \( '1' = '1' \) \) AND \( \((?:eQFetchRule[ ]*=[ ]*'(?:[a-zA-Z0-9\.]+):(?:[A-Za-z0-9]+)\(([A-Za-z0-9_]+)\)'[ ]*[or]*[ ]*)+\) \)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\( \\( \'1\' = \'1\' \\) \\) AND \\( \\((?:eQFetchRule[ ]*=[ ]*\'(?:[a-zA-Z0-9\\.]+):(?:[A-Za-z0-9]+)\\(([A-Za-z0-9_]+)\\)\'[ ]*[or]*[ ]*)+\\) \\)', 'g')
const str = `( ( '1' = '1' ) ) AND ( (eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__Management)' or eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__CAE__Load__Geometry)' ) )`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);