re = /\( \( '1' = '1' \) \) AND \( \((?:eQFetchRule[ ]*=[ ]*'(?:[a-zA-Z0-9\.]+):(?:[A-Za-z0-9]+)\(([A-Za-z0-9_]+)\)'[ ]*[or]*[ ]*)+\) \)/
str = '( ( \'1\' = \'1\' ) ) AND ( (eQFetchRule = \'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__Management)\' or eQFetchRule = \'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__CAE__Load__Geometry)\' ) )'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result