import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\( \\( '1' = '1' \\) \\) AND \\( \\((?:eQFetchRule[ ]*=[ ]*'(?:[a-zA-Z0-9\\.]+):(?:[A-Za-z0-9]+)\\(([A-Za-z0-9_]+)\\)'[ ]*[or]*[ ]*)+\\) \\)";
final String string = "( ( '1' = '1' ) ) AND ( (eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__Management)' or eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__CAE__Load__Geometry)' ) )";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}