import Foundation
let pattern = #"\((([^)]+))\)\[(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\2] (\1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)