# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\((([^)]+))\)\[(.*?)\]/[\2] (\1)/g;t' <<< "(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz"