use strict;
my $str = '(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz';
my $regex = qr/\((([^)]+))\)\[(.*?)\]/p;
my $subst = '[\\2] (\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";