#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\((([^)]+))\)\[(.*?)\]"
Local $sString = "(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz" & @CRLF & _
"(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz"
Local $sSubst = "[\2] (\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)