package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((([^)]+))\)\[(.*?)\]`)
var str = `(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz`
var substitution = "[\2] (\1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}