re = /\((([^)]+))\)\[(.*?)\]/
str = '(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz'
subst = '[\\2] (\\1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result