$re = '/\((([^)]+))\)\[(.*?)\]/';
$str = '(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz';
$subst = "[\2] (\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;