import Foundation
let pattern = #"[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
another one
another blah
another
another two
Another one
another 1
another 10
extra one
Extra one
extra two
extra
extra blah
extra three
extra 1
extra 2
one more
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)