use strict;
my $str = 'another one
another blah
another
another two
Another one
another 1
another 10
extra one
Extra one
extra two
extra
extra blah
extra three
extra 1
extra 2
one more
';
my $regex = qr/[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}