#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more"
Local $sString = "another one" & @CRLF & _
"another blah" & @CRLF & _
"another" & @CRLF & _
"another two" & @CRLF & _
"Another one" & @CRLF & _
"another 1" & @CRLF & _
"another 10" & @CRLF & _
"extra one" & @CRLF & _
"Extra one" & @CRLF & _
"extra two" & @CRLF & _
"extra" & @CRLF & _
"extra blah" & @CRLF & _
"extra three" & @CRLF & _
"extra 1" & @CRLF & _
"extra 2" & @CRLF & _
"one more" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")