const regex = new RegExp('[A|a]nother (one|two|three)|[A|a]nother \\d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \\d+|(one|two|three|four) more', 'gm')
const str = `another one
another blah
another
another two
Another one
another 1
another 10
extra one
Extra one
extra two
extra
extra blah
extra three
extra 1
extra 2
one more
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}