// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more").unwrap();
let string = "another one
another blah
another
another two
Another one
another 1
another 10
extra one
Extra one
extra two
extra
extra blah
extra three
extra 1
extra 2
one more
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}