import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A|a]nother (one|two|three)|[A|a]nother \\d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \\d+|(one|two|three|four) more";
final String string = "another one\n"
+ "another blah\n"
+ "another\n"
+ "another two\n"
+ "Another one\n"
+ "another 1\n"
+ "another 10\n"
+ "extra one\n"
+ "Extra one\n"
+ "extra two\n"
+ "extra\n"
+ "extra blah\n"
+ "extra three\n"
+ "extra 1\n"
+ "extra 2\n"
+ "one more\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}