re = /[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more/m
str = 'another one
another blah
another
another two
Another one
another 1
another 10
extra one
Extra one
extra two
extra
extra blah
extra three
extra 1
extra 2
one more
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end