import Foundation
let pattern = #"^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.fanball.com
https://www.fanball.com/
https://www.fanball.com/lobby
https://staging.fanball.com
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://fanball-qa.shub.dog
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)