const regex = /^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(((www|staging)\\.fanball\\.com\\\/?$)|fanball-qa\\.shub\\.dog\\\/?$)', 'gm')
const str = `https://www.fanball.com
https://www.fanball.com/
https://www.fanball.com/lobby
https://staging.fanball.com
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://fanball-qa.shub.dog
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}