using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)";
string input = @"https://www.fanball.com
https://www.fanball.com/
https://www.fanball.com/lobby
https://staging.fanball.com
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://fanball-qa.shub.dog
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}