// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)").unwrap();
let string = "https://www.fanball.com
https://www.fanball.com/
https://www.fanball.com/lobby
https://staging.fanball.com
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://fanball-qa.shub.dog
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}