$re = '/^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)/m';
$str = 'https://www.fanball.com
https://www.fanball.com/
https://www.fanball.com/lobby
https://staging.fanball.com
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://fanball-qa.shub.dog
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);