import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(((www|staging)\\.fanball\\.com\\/?$)|fanball-qa\\.shub\\.dog\\/?$)";
final String string = "https://www.fanball.com\n"
+ "https://www.fanball.com/\n"
+ "https://www.fanball.com/lobby\n"
+ "https://staging.fanball.com\n"
+ "https://staging.fanball.com/\n"
+ "https://staging.fanball.com/lobby\n"
+ "https://fanball-qa.shub.dog\n"
+ "https://fanball-qa.shub.dog/\n"
+ "https://fanball-qa.shub.dog/lobby";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}