#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(((www|staging)\.fanball\.com\/?$)|fanball-qa\.shub\.dog\/?$)"
Local $sString = "https://www.fanball.com" & @CRLF & _
"https://www.fanball.com/" & @CRLF & _
"https://www.fanball.com/lobby" & @CRLF & _
"https://staging.fanball.com" & @CRLF & _
"https://staging.fanball.com/" & @CRLF & _
"https://staging.fanball.com/lobby" & @CRLF & _
"https://fanball-qa.shub.dog" & @CRLF & _
"https://fanball-qa.shub.dog/" & @CRLF & _
"https://fanball-qa.shub.dog/lobby"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")