import Foundation
let pattern = #"><w:p .*(?<=\[TICKET_LIST]).*<\/w:p><"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<w:p w14:paraId="10B783DF" w14:textId="583D4857" w:rsidR="00E12D7A" w:rsidRDefault="00E12D7A" w:rsidP="0029638C"><w:pPr><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr></w:pPr><w:r w:rsidRPr="00E12D7A"><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id="0" w:name="_GoBack"/><w:bookmarkEnd w:id="0"/></w:p><w:p w14:paraId="10B783DF" w14:textId="583D4857" w:rsidR="00E12D7A" w:rsidRDefault="00E12D7A" w:rsidP="0029638C"><w:pPr><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr></w:pPr><w:r w:rsidRPr="00E12D7A"><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr><w:t>[TICKET_LIST]</w:t></w:r><w:bookmarkStart w:id="0" w:name="_GoBack"/><w:bookmarkEnd w:id="0"/></w:p><w:p w14:paraId="10B783DF" w14:textId="583D4857" w:rsidR="00E12D7A" w:rsidRDefault="00E12D7A" w:rsidP="0029638C"><w:pPr><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr></w:pPr><w:r w:rsidRPr="00E12D7A"><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id="0" w:name="_GoBack"/><w:bookmarkEnd w:id="0"/></w:p><w:p w14:paraId="10B783DF" w14:textId="583D4857" w:rsidR="00E12D7A" w:rsidRDefault="00E12D7A" w:rsidP="0029638C"><w:pPr><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr></w:pPr><w:r w:rsidRPr="00E12D7A"><w:rPr><w:rFonts w:ascii="HelveticaNeueLT Pro 45 Lt" w:hAnsi="HelveticaNeueLT Pro 45 Lt" w:cs="HelveticaNeue"/><w:b/><w:bCs/><w:lang w:val="en-GB"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id="0" w:name="_GoBack"/><w:bookmarkEnd w:id="0"/></w:p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)