# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"><w:p .*(?<=\[TICKET_LIST]).*<\/w:p><"
test_str = "<w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t>[TICKET_LIST]</w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.