import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "><w:p .*(?<=\\[TICKET_LIST]).*<\\/w:p><";
final String string = "<w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t>[TICKET_LIST]</w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p><w:p w14:paraId=\"10B783DF\" w14:textId=\"583D4857\" w:rsidR=\"00E12D7A\" w:rsidRDefault=\"00E12D7A\" w:rsidP=\"0029638C\"><w:pPr><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr></w:pPr><w:r w:rsidRPr=\"00E12D7A\"><w:rPr><w:rFonts w:ascii=\"HelveticaNeueLT Pro 45 Lt\" w:hAnsi=\"HelveticaNeueLT Pro 45 Lt\" w:cs=\"HelveticaNeue\"/><w:b/><w:bCs/><w:lang w:val=\"en-GB\"/></w:rPr><w:t></w:t></w:r><w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/><w:bookmarkEnd w:id=\"0\"/></w:p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}