import Foundation
let pattern = #".*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
var a = 776644%94536;
document.getElementById('dlbutton').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";
if (document.getElementById('fimage')) {
document.getElementById('fimage').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)