const regex = /.*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/d\\\/([a-zA-Z]*)\\\/.*\\\/(\\d+_\\d+\\.mp4).*', 'g')
const str = `var a = 776644%94536;
document.getElementById('dlbutton').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";
if (document.getElementById('fimage')) {
document.getElementById('fimage').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}