#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*"
Local $sString = "var a = 776644%94536;" & @CRLF & _
" document.getElementById('dlbutton').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";" & @CRLF & _
" if (document.getElementById('fimage')) {" & @CRLF & _
" document.getElementById('fimage').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")