use strict;
my $str = 'var a = 776644%94536;
document.getElementById(\'dlbutton\').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";
if (document.getElementById(\'fimage\')) {
document.getElementById(\'fimage\').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";
}';
my $regex = qr/.*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}