package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*`)
var str = `var a = 776644%94536;
document.getElementById('dlbutton').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";
if (document.getElementById('fimage')) {
document.getElementById('fimage').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}