re = /.*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*/
str = 'var a = 776644%94536;
document.getElementById(\'dlbutton\').href = "/d/lHCIDyYJ/"+a+"/2842_4.mp4";
if (document.getElementById(\'fimage\')) {
document.getElementById(\'fimage\').href = "/i/lHCIDyYJ/"+a+"/2842_4.mp4";
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end