import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/d\\/([a-zA-Z]*)\\/.*\\/(\\d+_\\d+\\.mp4).*";
final String string = "var a = 776644%94536;\n"
+ " document.getElementById('dlbutton').href = \"/d/lHCIDyYJ/\"+a+\"/2842_4.mp4\";\n"
+ " if (document.getElementById('fimage')) {\n"
+ " document.getElementById('fimage').href = \"/i/lHCIDyYJ/\"+a+\"/2842_4.mp4\";\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}