import Foundation
let pattern = #"at (\w+\.)(\w+\.)*createChildControlsAsync"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Error
at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)
at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)
at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)
at Array.<anonymous> (sharespace.js?v=14506632:17421)
at c (sharespace.js?v=14506632:4)
at Object.add [as done] (sharespace.js?v=14506632:4)
at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)
at _renderCallback (sharespace.js?v=14506632:2437)
at <anonymous>:1:69
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)