#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "at (\w+\.)(\w+\.)*createChildControlsAsync"
Local $sString = "Error" & @CRLF & _
" at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)" & @CRLF & _
" at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)" & @CRLF & _
" at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)" & @CRLF & _
" at Array.<anonymous> (sharespace.js?v=14506632:17421)" & @CRLF & _
" at c (sharespace.js?v=14506632:4)" & @CRLF & _
" at Object.add [as done] (sharespace.js?v=14506632:4)" & @CRLF & _
" at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)" & @CRLF & _
" at _renderCallback (sharespace.js?v=14506632:2437)" & @CRLF & _
" at <anonymous>:1:69"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")