# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"at (\w+\.)(\w+\.)*createChildControlsAsync"
test_str = ("Error\n"
" at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)\n"
" at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)\n"
" at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)\n"
" at Array.<anonymous> (sharespace.js?v=14506632:17421)\n"
" at c (sharespace.js?v=14506632:4)\n"
" at Object.add [as done] (sharespace.js?v=14506632:4)\n"
" at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)\n"
" at _renderCallback (sharespace.js?v=14506632:2437)\n"
" at <anonymous>:1:69")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.