const regex = /at (\w+\.)(\w+\.)*createChildControlsAsync/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('at (\\w+\\.)(\\w+\\.)*createChildControlsAsync', 'g')
const str = `Error
at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)
at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)
at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)
at Array.<anonymous> (sharespace.js?v=14506632:17421)
at c (sharespace.js?v=14506632:4)
at Object.add [as done] (sharespace.js?v=14506632:4)
at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)
at _renderCallback (sharespace.js?v=14506632:2437)
at <anonymous>:1:69`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}