use strict;
my $str = 'Error
at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)
at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)
at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)
at Array.<anonymous> (sharespace.js?v=14506632:17421)
at c (sharespace.js?v=14506632:4)
at Object.add [as done] (sharespace.js?v=14506632:4)
at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)
at _renderCallback (sharespace.js?v=14506632:2437)
at <anonymous>:1:69';
my $regex = qr/at (\w+\.)(\w+\.)*createChildControlsAsync/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}