import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "at (\\w+\\.)(\\w+\\.)*createChildControlsAsync";
final String string = "Error\n"
+ " at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)\n"
+ " at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)\n"
+ " at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)\n"
+ " at Array.<anonymous> (sharespace.js?v=14506632:17421)\n"
+ " at c (sharespace.js?v=14506632:4)\n"
+ " at Object.add [as done] (sharespace.js?v=14506632:4)\n"
+ " at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)\n"
+ " at _renderCallback (sharespace.js?v=14506632:2437)\n"
+ " at <anonymous>:1:69";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}