$re = '/at (\w+\.)(\w+\.)*createChildControlsAsync/';
$str = 'Error
at EndlessScrollingRepeater.Control.ensureChildControls (sharespace.js?v=14506632:2296)
at EndlessScrollingRepeater.Control.init (sharespace.js?v=14506632:2278)
at NewsTileListWebPart.Control.addChild (sharespace.js?v=14506632:2417)
at Array.<anonymous> (sharespace.js?v=14506632:17421)
at c (sharespace.js?v=14506632:4)
at Object.add [as done] (sharespace.js?v=14506632:4)
at NewsTileListWebPart.NewsListWebPart.createChildControlsAsync (sharespace.js?v=14506632:17404)
at _renderCallback (sharespace.js?v=14506632:2437)
at <anonymous>:1:69';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);