// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[sife]+)(\=.*)").unwrap();
let string = "MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2";
let substitution = "MEDAISOUP_LISTEN_IP=1111";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}