re = /(^[sife]+)(\=.*)/m
str = 'MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2'
subst = 'MEDAISOUP_LISTEN_IP=1111'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result