# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[sife]+)(\=.*)/MEDAISOUP_LISTEN_IP=1111/gm;t' <<< "MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2"