using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[sife]+)(\=.*)";
string substitution = @"MEDAISOUP_LISTEN_IP=1111";
string input = @"MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}