use strict;
my $str = 'MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2';
my $regex = qr/(^[sife]+)(\=.*)/mp;
my $subst = 'MEDAISOUP_LISTEN_IP=1111';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";