#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[sife]+)(\=.*)"
Local $sString = "MEDAISOUP_LISTEN_IP=123.123.123" & @CRLF & _
"Mohannad=1" & @CRLF & _
"sife=2"
Local $sSubst = "MEDAISOUP_LISTEN_IP=1111"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)