import Foundation
let pattern = #"ng-click="vm\.onClickTab\((.*?)'\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" ng-click="vm.onClickTab('wanted')""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ng-click="vm\.onClickTab\($1', $event\)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)