package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ng-click="vm\.onClickTab\((.*?)'\)`)
var str = ` ng-click="vm.onClickTab('wanted')"`
var substitution = "ng-click="vm\.onClickTab\($1', $event\)"
fmt.Println(re.ReplaceAllString(str, substitution))
}